Is Aperture 3.1.2 corrupted and won’t start?

You are trying to start Aperture, but every time you click on it you get an error like this one. Library not loaded: /Library/Frameworks/PluginManager.framework/Versions/B/PluginManagerwpid-problemreportforaperture-2012-09-29-19-58.png

No need to reinstall aperture, simply replace the PluginManager file located in the /Library/Frameworks/PluginManager.framework/Versions/B folder. On my system, the B folder was missing so I had to recreate it. You can get a clean working copy of the file from mikeherdes here http://qvenon.com/files/PluginManager.zip. If the link is broken, find a friend with a working install and copy theirs.

wpid-versions-2012-09-29-19-58.png

Did that work for you? Leave a comment. The thanks for figuring this out goes to these guys. http://forums.macrumors.com/archive/index.php/t-1088985.html

Advertisements

About spuder
spuder is a "super computer" support engineer by day, and tinkerer / hobbyist by night.

One Response to Is Aperture 3.1.2 corrupted and won’t start?

  1. vlad says:

    Works fine, thanks. This was caused by Final Cut Pro upgrade which replaced the PluginManager binary with one which supported only ppc and 32-bit i386 architecture therefore Aperture which is 64-bit x86 binary could not be started. Replacing the binary with one which supports all 3 architectures fixes the problem.

    before:

    $ file /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager
    /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager: Mach-O universal binary with 2 architectures
    /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager (for architecture ppc): Mach-O dynamically linked shared library ppc
    /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager (for architecture i386): Mach-O dynamically linked shared library i386

    after the fix:

    $ file /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager
    /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager: Mach-O universal binary with 3 architectures
    /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager (for architecture ppc7400): Mach-O dynamically linked shared library ppc
    /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager (for architecture i386): Mach-O dynamically linked shared library i386
    /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager (for architecture x86_64): Mach-O 64-bit dynamically linked shared library x86_64

    Apple notes the issue http://support.apple.com/kb/TS3528 however does not offer any automatic update which is weird since reinstalling is not the option, more so that the redelivery is trivial.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: